back to overview
resolved

network infrastructure maintenance

Jul 22, 2026 at 10:15am UTC  –  Jul 22, 2026 at 10:45am UTC
affected services
pds.ebil.club
git.koi.rip

resolved
Jul 22, 2026 at 10:45am UTC

maintenance ended

created
Jul 22, 2026 at 10:15am UTC

stuff