back to overview
downtime

router exploded

May 20, 2026 at 12:38am UTC
affected services
pds.ebil.club
git.koi.rip

resolved
May 20, 2026 at 1:05am UTC

recovered

created
May 20, 2026 at 12:38am UTC

wtf