back to overview
downtime

power outage

May 15, 2026 at 3:38am UTC
affected services
pds.ebil.club
git.koi.rip

resolved
May 15, 2026 at 10:39am UTC

there seem to have been issues with cloudflared tunnels. all resolved now

updated
May 15, 2026 at 3:44am UTC

power back !!

created
May 15, 2026 at 3:38am UTC

power went out for a second