back to overview
downtime

power outage

Apr 24, 2026 at 1:20pm UTC
affected services
pds.ebil.club
git.koi.rip

resolved
Apr 24, 2026 at 2:25pm UTC

power went out for an hour :c

created
Apr 24, 2026 at 1:20pm UTC

power went out... will be gone for over an hour. very tragic :c